Vision API is currently experiencing processing delays on the hour and half hour

Incident Report for Truepic

Resolved

The mitigating functionality that we put in place approximately one hour ago was successful and we are no longer seeing performance issues on the Vision API and within the Vision dashboard.
Posted Feb 20, 2026 - 13:40 EST

Identified

The root issue has been identified and we are implementing mitigating functionality and testing now.
Posted Feb 20, 2026 - 12:52 EST

Investigating

We are currently investigating an issue where the Vision API is experiencing delays every 30 minutes on the hour and half hour that began early this morning. This impacts API calls and Vision Dashboard login at these times and clears quickly. We are increasing our capacity to handle the increased incoming API volume that is happening at those times and expect to have this issue resolved shortly.
Posted Feb 20, 2026 - 10:40 EST
This incident affected: Vision API and Vision Dashboard.